GX2 (MyCority) - Degraded Performance (US2-2)

Incident Report for CorityOne

Resolved

This incident has been resolved.
Posted Jun 29, 2026 - 17:24 UTC

Investigating

We are currently investigating an issue affecting the GX2 (MyCority) service in the US2-2 cluster.
Our team is actively working to identify the root cause and will provide further updates as soon as more information becomes available.
Posted Jun 29, 2026 - 16:50 UTC
This incident affected: US2-2 (MyCority-US2-2).