Resolved
Mitigation efforts have been successfully completed, and the issue affecting portions of the MyCority platform and REST API services has been resolved.
Service has been restored across all affected regions, and the platform is operating normally.
Posted Jul 01, 2026 - 00:40 UTC
Monitoring
Mitigation efforts have been completed, and the platform has been successfully restored to the previously validated v2026.1.0.18 release across all affected regions and clusters.
We are actively monitoring the platform to confirm stability. Customers should no longer experience the previously reported performance degradation, including "MG-000428, Execution Timeout Expired" errors.
We will continue to monitor the platform closely and provide a final update once we have confirmed the issue has been fully resolved.
Posted Jun 30, 2026 - 21:30 UTC
Update
Mitigation efforts are progressing as planned. Service has been restored in the affected regions where recovery has been completed. Restoration activities continue for the remaining regions.
Customers in the remaining affected regions may continue to experience intermittent performance degradation, including "MG-000428, Execution Timeout Expired" errors.
We are closely monitoring the platform and will provide another update once full service has been restored.
Posted Jun 30, 2026 - 20:28 UTC
Identified
We have identified the cause of the degraded performance affecting portions of the MyCority platform and REST API services.
As part of our mitigation efforts, we are restoring the platform to the previously validated v2026.1.0.18 release. During this process, users may continue to experience intermittent performance degradation or brief service interruptions affecting GX2 MyCority and REST API services.
Posted Jun 30, 2026 - 18:31 UTC
Update
We are continuing to investigate this issue.
Posted Jun 30, 2026 - 18:22 UTC
Investigating
We are currently investigating an issue causing degraded performance affecting portions of the MyCority platform and REST API services.
Users may experience slower response times, intermittent errors, or delays when accessing the application or API endpoints.
Our engineering teams are actively investigating the issue and working to restore normal service as quickly as possible. We will provide further updates as more information becomes available.
Posted Jun 30, 2026 - 17:33 UTC
This incident affected: US2-1 (GX2-US2-1, MyCority-US2-1, API-US2-1), US2-2 (GX2-US2-2, MyCority-US2-2, API-US2-2), US2-0 (GX2-US2-0, MyCority-US2-0, API-US2-0), FedRAMP (GX2-FedRAMP, MyCority-FedRAMP, API-FedRAMP), CA1-0 (GX2-CA1-0, MyCority-CA1-0, API-CA1-0), CA1-1 (GX2-CA1-1, MyCority-CA1-1, API-CA1-1), CA1-2 (GX2-CA1-2, MyCority-CA1-2, API-CA1-2), EU1-0 (GX2-EU1-0, MyCority-EU1-0, API-EU1-0), EU1-1 (GX2-EU1-1, MyCority-EU1-1, API-EU1-1), UK2-0 (GX2-UK2-0, MyCority-UK2-0, API-UK2-0), AU2-0 (GX2-AU2-0, MyCority-AU2-0, API-AU2-0), US1-0 (GX2-US1-0, MyCority-US1-0, API-US1-0), and EUW2-0 (GX2-EUW2-0, MyCority-EUW2-0, API-EUW2-0).