The issue affecting GX2 on US2-0 has been resolved, and all systems are back to normal. We appreciate your patience and apologize for any inconvenience caused.
Posted Mar 21, 2025 - 11:36 EDT
Monitoring
A fix has been implemented and we are currently monitoring the situation to ensure everything is functioning as expected. We will confirm full resolution soon. Thank you for your patience.
Posted Mar 21, 2025 - 10:20 EDT
Investigating
We are currently investigating a performance degradation affecting GX2 on US2-0. Our team is working to identify the cause and will provide an update as soon as more information is available. Thank you for your patience.