Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Oct 09, 2025 - 14:00 EDT
Scheduled
Dear Reporting 21 Client,
A scheduled release for your Reporting 21 environment has been created. This release includes updates and improvements to enhance the platform’s performance and functionality.
Sincerely, The Cority Hosting Team
Posted Sep 29, 2025 - 10:18 EDT
This scheduled maintenance affected: R21-EU (Platform, R21).